Daemon Power

The NetBSD Packages Collection: graphics/ruby-cairo-gobject

Brief description of the package:
Ruby binding of cairo-gobject

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://ruby-gnome2.osdn.jp/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "graphics/ruby-cairo-gobject" directory. The current source version of the package is "ruby26-cairo-gobject-3.4.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/ruby-cairo-gobject :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-glib2>=3.4.2 ruby26-native-package-installer>=1.0.3 ruby26-base>=2.6.6 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby26-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.8 glib2>=2.64.0nb1 ruby26-cairo>=1.16.2 ruby26-pkg-config>=1.2.2 cairo>=1.2.0 Xrender>=0.2 x11-links>=1.31 osabi-NetBSD-9.0_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 ruby26-pkg-config-[0-9]* ruby26-glib2>=3.3.8 ruby26-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby26-glib2>=3.4.1nb1 ruby26-cairo>=1.16.2nb1 cairo-gobject>=1.16.0nb4 .

This package requires the following package(s) to run: ruby26-glib2>=3.4.2 ruby26-native-package-installer>=1.0.3 ruby26-base>=2.6.6 libyaml>=0.1.1 libyaml>=0.1.4 ruby26-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 glib2>=2.64.0nb1 ruby26-cairo>=1.16.2 ruby26-pkg-config>=1.2.2 cairo>=1.2.0 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.16.0 ruby26-glib2>=3.3.8 ruby26-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby26-glib2>=3.4.1nb1 ruby26-cairo>=1.16.2nb1 cairo-gobject>=1.16.0nb4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
aarch64:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
aarch64:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
aarch64:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
alpha:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
alpha:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
alpha:ruby26-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
alpha:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
alpha:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
alpha:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv4:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
earmv4:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
earmv4:ruby26-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv6hf:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv6hf:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv6hf:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
earmv7hf:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
earmv7hf:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
i386:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 7.0)
i386:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 7.0)
i386:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 7.0)
i386:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 7.0)
i386:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 7.1)
i386:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 7.1)
i386:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 7.1)
i386:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 7.1)
i386:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 7.1)
i386:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 7.1)
i386:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 7.1)
i386:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
i386:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
i386:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
i386:ruby26-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
i386:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
i386:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
i386:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
i386:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
i386:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
i386:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
i386:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
i386:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
i386:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
i386:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
i386:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
i386:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
i386:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
mips64eb:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
mips64eb:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
mips64eb:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
powerpc:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
powerpc:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
sparc64:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby26-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
sparc64:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
sparc64:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
sparc:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
sparc:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby24-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 7.0)
x86_64:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 7.0)
x86_64:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 7.0)
x86_64:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 7.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 7.1)
x86_64:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 7.1)
x86_64:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 7.1)
x86_64:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 7.1)
x86_64:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 7.1)
x86_64:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 7.1)
x86_64:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 7.1)
x86_64:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
x86_64:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
x86_64:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
x86_64:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 8.0)
x86_64:ruby24-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby25-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby26-cairo-gobject-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 8.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby24-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby25-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.1.tgz(NetBSD 9.0)
x86_64:ruby24-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
x86_64:ruby27-cairo-gobject-3.4.1nb1.tgz(NetBSD 9.0)
x86_64:ruby25-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-cairo-gobject-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-cairo-gobject-3.4.2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]