Daemon Power

The NetBSD Packages Collection: graphics/digikam

Brief description of the package:
Advanced digital photo management application (KDE4)

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.digikam.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "graphics/digikam" directory. The current source version of the package is "digikam-4.13.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/digikam :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: qt4-sqlite3-[0-9]* qt4-libs>=4.8.7 glu>=3.4.2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 x11-links>=1.01 osabi-NetBSD-7.0 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.38 libdrm>=2.4.15 libelf>=0.8.5 libLLVM>=3.7.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.11 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* dri2proto>=2.1 dri2proto>=2.0 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xrender>=0.8 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb6 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-libs>=4.8.6nb5 qt4-tools>=4.1.0 libtool-base-[0-9]* qt4-tools>=4.8.6nb3 gnupg2>=2.0<2.1 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.11 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 dirmngr>=0.9.3nb1 pth>=2.0.0 pth>=2.0.7nb1 pth>=2.0.0nb2 libgpg-error>=1.4 libgcrypt>=1.5.0 libksba>=1.0.2 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 dirmngr>=0.9.3nb2 curl>=7.35.0nb1 perl>=5.0 liblqr>=0.4.1 glib2>=2.4.0 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 kdepimlibs4>=4.0.0 qt4-libs>=4.4.0 qt4-qdbus>=4.3.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 bash-[0-9]* libxslt>=1.1.8 libxml2>=2.6.27 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 boost-libs-1.60.* icu>=3.4 icu>=56.1 boost-headers-1.60.* boost-jam-1.60.* qjson>=0.7.1 akonadi>=1.8.51 shared-mime-info>=0.15 shared-mime-info>=1.0nb1 boost-libs>=1.60.0 qt4-qdbus>=4.8.6nb1 automoc4>=0.9.87 libxslt-[0-9]* akonadi>=0.82.0 cyrus-sasl>=2.1.12 gpgme>=0.9.0 libassuan>=2.0.2 libical>=0.42 zonetab-[0-9]* kdelibs4>=4.0.0 docbook-xsl>=1.75 qt4-tools>=4.4.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 libclucene>=2.3.3.4 libclucene>=2.2.0 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb5 fam>=2.7.0nb7 strigi>=0.6.2 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 automoc4>=0.9.83 polkit-qt>=0.9.2 policykit>=0.9 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 dbus-glib>=0.100nb1 policykit>=0.9nb12 qca2>=2.0.0 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libXScrnSaver>=1.1.2 scrnsaverproto>=1.2.0 scrnsaverproto>=1.1.0 libXpm>=3.5.4.2 libXtst>=1.0.1 recordproto>=1.13.99.1 recordproto>=1.13.1 xextproto>=7.0.99.3 desktop-file-utils>=0.8 strigi>=0.7.8nb11 grantlee>=0.5.1nb1 libdbusmenu-qt>=0.9.2nb12 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb2 phonon>=4.8.2nb2 polkit-qt>=0.9.4nb18 qca2>=2.0.3nb19 aspell>=0.60.6nb3 enchant>=1.6.0nb5 desktop-file-utils>=0.10nb1 akonadi>=1.13.0nb3 cyrus-sasl>=2.1.26 gpgme>=1.3.0nb1 kdelibs4>=4.14.15 mysql-server>=5.5.11<5.6 mysql-client>=5.5.10<5.6 mysql-client>=5.5.36nb1 libgphoto2>=2.1.2 libltdl>=2.4.2 libusb>=0.1.7 libexif>=0.6.11 libltdl>=2.2.6 libusb>=0.1.8nb2 libexif>=0.6.20nb1 lcms>=1.06 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 libkdcraw>=4.8.0 libraw>=0.16.0 lcms2>=2.2 libkexiv2>=4.8.0 libkipi>=4.8.0 libksane>=4.8.0 sane-backends>=1.0.3 libusb1>=1.0.9 sane-backends>=1.0.24 libkface>=2.5.0 opencv>=3.0.0 libwebp>=0.2.0 py27-numpy>=1.0 g95>=0.91 blas>=1.0nb2 libtool-fortran>=2.2.6bnb3 lapack>=3.1.1 blas>=1.0nb3 gtk2+>=2.4.0 atk>=1.30.0 glib2>=2.31.2 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.44.0 libffi>=3.0.0 gobject-introspection>=1.34.0 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 Xft2>=2.1.2nb2 libXi>=1.3.0 inputproto>=2.3 xextproto>=7.0.3 xproto>=7.0.13 libXi>=1.0.0 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fontconfig>=2.10.91 glib2>=2.33.12 harfbuzz>=0.9.9 harfbuzz>=0.9.4 cairo>=1.12.10 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.30.0 pixman>=0.25.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 glib2>=2.14.0 cairo>=1.14.2nb1 harfbuzz>=0.9.17nb2 cairo-gobject>=1.14.2nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.22.0 perl<5.24.0 pango>=1.6.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.26.5nb2 pango>=1.36.8nb1 gobject-introspection>=0.9.3 libwebp>=0.5.0 gtk2+>=2.24.27nb2 opencv-contrib-face>=3.0.0 libpgf>=6.14.12 dos2unix-[0-9]* libkgeomap>=2.5.0 marble>=4.8.0 marble>=4.14.3nb2 libkvkontakte>=2.5.0 baloo>=4.14.3 kfilemetadata>=4.14.3 taglib>=1.0 kdegraphics-mobipocket>=4.14.3 ffmpeg2>=2.0 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 enca>=1.9 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 yasm>=0.4.0 libvpx>=1.5.0 yasm-[0-9]* libass>=0.11.2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 yasm>=0.7.2 poppler-qt4>=0.6.1 openjpeg>=2.1.0 poppler>=0.40.0 poppler>=0.5.1 qt4-libs>=4.7.0 ebook-tools>=0.1.1 libzip>=0.7.1 libzip>=1.0 cmake>=2.8.5nb1 libarchive>=3.0.0 libarchive>=3.1 libarchive>=3.1.2 taglib>=1.9.1 kdegraphics-mobipocket>=4.14.3nb2 ffmpeg2>=2.8.2nb1 poppler-qt4>=0.40.0 ebook-tools>=0.1.1nb5 xapian>=1.0.7 libuuid>=2.18 kdepimlibs4>=4.14.3nb3 xapian>=1.2.2nb1 libmediawiki>=2.5.0 liblqr>=0.4.1nb5 mysql-server>=5.5.29nb1<5.6 libgphoto2>=2.4.7nb3 lcms>=1.12nb2 libkdcraw>=4.14.3nb2 libkipi>=4.14.3nb2 libksane>=4.14.3nb2 libkface>=4.4.0nb2 libkgeomap>=4.4.0nb2 libkvkontakte>=4.4.0nb2 libmediawiki>=4.4.0nb2 eigen3>=3.1.2 .

This package requires the following package(s) to run: qt4-sqlite3-[0-9]* qt4-libs>=4.8.7 glu>=3.4.2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.38 libdrm>=2.4.15 libelf>=0.8.5 libLLVM>=3.7.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb6 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-libs>=4.8.6nb5 gnupg2>=2.0<2.1 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.11 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 dirmngr>=0.9.3nb1 pth>=2.0.0 pth>=2.0.7nb1 pth>=2.0.0nb2 libgpg-error>=1.4 libgcrypt>=1.5.0 libksba>=1.0.2 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 dirmngr>=0.9.3nb2 curl>=7.35.0nb1 perl>=5.0 liblqr>=0.4.1 glib2>=2.4.0 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.34.0 kdepimlibs4>=4.0.0 qt4-libs>=4.4.0 qt4-qdbus>=4.3.2 dbus>=0.91 boost-libs-1.60.* icu>=3.4 icu>=56.1 qjson>=0.7.1 akonadi>=1.8.51 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 shared-mime-info>=1.0nb1 boost-libs>=1.60.0 qt4-qdbus>=4.8.6nb1 akonadi>=0.82.0 cyrus-sasl>=2.1.12 gpgme>=0.9.0 libassuan>=2.0.2 libical>=0.42 zonetab-[0-9]* kdelibs4>=4.0.0 docbook-xml>=4.2 docbook-xsl>=1.75 qt4-tools>=4.4.0 libtool-base-[0-9]* qt4-tools>=4.1.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 libclucene>=2.3.3.4 libclucene>=2.2.0 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb5 fam>=2.7.0nb7 strigi>=0.6.2 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 qt4-tools>=4.8.6nb3 polkit-qt>=0.9.2 policykit>=0.9 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 dbus-glib>=0.100nb1 policykit>=0.9nb12 qca2>=2.0.0 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libxslt>=1.1.8 libxml2>=2.6.27 libXScrnSaver>=1.1.2 libXpm>=3.5.4.2 libXtst>=1.0.1 desktop-file-utils>=0.8 strigi>=0.7.8nb11 grantlee>=0.5.1nb1 libdbusmenu-qt>=0.9.2nb12 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb2 phonon>=4.8.2nb2 polkit-qt>=0.9.4nb18 qca2>=2.0.3nb19 aspell>=0.60.6nb3 enchant>=1.6.0nb5 libxslt>=1.1.28nb2 desktop-file-utils>=0.10nb1 akonadi>=1.13.0nb3 cyrus-sasl>=2.1.26 gpgme>=1.3.0nb1 kdelibs4>=4.14.15 mysql-server>=5.5.11<5.6 mysql-client>=5.5.10<5.6 mysql-client>=5.5.36nb1 libgphoto2>=2.1.2 libltdl>=2.4.2 libusb>=0.1.7 libexif>=0.6.11 libltdl>=2.2.6 libusb>=0.1.8nb2 libexif>=0.6.20nb1 lcms>=1.06 tiff>=3.6.1 jbigkit>=2.0 tiff>=4.0.3nb5 libkdcraw>=4.8.0 libraw>=0.16.0 lcms2>=2.2 libkexiv2>=4.8.0 libkipi>=4.8.0 libksane>=4.8.0 sane-backends>=1.0.3 libusb1>=1.0.9 sane-backends>=1.0.24 libkface>=2.5.0 opencv>=3.0.0 libwebp>=0.2.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 py27-numpy>=1.0 g95>=0.91 blas>=1.0nb2 lapack>=3.1.1 blas>=1.0nb3 python27>=2.7.1nb2 gtk2+>=2.4.0 py27-expat-[0-9]* atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fontconfig>=2.10.91 glib2>=2.33.12 harfbuzz>=0.9.9 harfbuzz>=0.9.4 cairo>=1.12.10 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.30.0 pixman>=0.25.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 glib2>=2.14.0 cairo>=1.14.2nb1 harfbuzz>=0.9.17nb2 cairo-gobject>=1.14.2nb1 pango>=1.6.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.26.5nb2 pango>=1.36.8nb1 libwebp>=0.5.0 gtk2+>=2.24.27nb2 opencv-contrib-face>=3.0.0 libpgf>=6.14.12 libkgeomap>=2.5.0 marble>=4.8.0 marble>=4.14.3nb2 libkvkontakte>=2.5.0 baloo>=4.14.3 kfilemetadata>=4.14.3 taglib>=1.0 kdegraphics-mobipocket>=4.14.3 ffmpeg2>=2.0 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 enca>=1.9 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 libvpx>=1.5.0 libass>=0.11.2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 poppler-qt4>=0.6.1 openjpeg>=2.1.0 poppler>=0.40.0 poppler>=0.5.1 qt4-libs>=4.7.0 ebook-tools>=0.1.1 libzip>=0.7.1 libzip>=1.0 taglib>=1.9.1 kdegraphics-mobipocket>=4.14.3nb2 ffmpeg2>=2.8.2nb1 poppler-qt4>=0.40.0 ebook-tools>=0.1.1nb5 xapian>=1.0.7 libuuid>=2.18 kdepimlibs4>=4.14.3nb3 xapian>=1.2.2nb1 libmediawiki>=2.5.0 liblqr>=0.4.1nb5 mysql-server>=5.5.29nb1<5.6 libgphoto2>=2.4.7nb3 lcms>=1.12nb2 libkdcraw>=4.14.3nb2 libkipi>=4.14.3nb2 libksane>=4.14.3nb2 libkface>=4.4.0nb2 libkgeomap>=4.4.0nb2 libkvkontakte>=4.4.0nb2 libmediawiki>=4.4.0nb2 .

This package supports the following build-time options:

debug
Enable debugging facilities in the package.
lensfun
Enable lensfun (camera lens distortion rectifyer) support.
liblqr
Enable liblqr (liquid rescale) support.
pim
Enable pim (personal information management) support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:digikam-4.4.0.tgz(NetBSD 6.0)
i386:digikam-4.4.0nb3.tgz(NetBSD 6.0)
i386:digikam-4.4.0nb3.tgz(NetBSD 6.0)
i386:digikam-4.4.0.tgz(NetBSD 6.1)
i386:digikam-4.4.0nb3.tgz(NetBSD 6.1)
i386:digikam-4.4.0nb3.tgz(NetBSD 6.1)
i386:digikam-4.4.0nb3.tgz(NetBSD 7.0)
i386:digikam-4.13.0.tgz(NetBSD 7.0)
x86_64:digikam-4.4.0.tgz(NetBSD 6.0)
x86_64:digikam-4.4.0nb3.tgz(NetBSD 6.0)
x86_64:digikam-4.4.0nb3.tgz(NetBSD 6.0)
x86_64:digikam-4.4.0.tgz(NetBSD 6.1)
x86_64:digikam-4.4.0nb3.tgz(NetBSD 6.1)
x86_64:digikam-4.4.0nb3.tgz(NetBSD 6.1)
x86_64:digikam-4.4.0nb3.tgz(NetBSD 7.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]