games/xdemineur - The NetBSD Packages Collection

Minesweeper game for the X Window System

Xdemineur is a minesweeper game for the X Window System.

The object of this game is to find the location of the mines hidden in the
minefield and to mark their location by placing a warning flag.  You have
exactly as many flags as there are mines.  The number of flags that remain to
be placed is displayed in the top left corner of the window and a timer is
displayed in the top right corner.

The game is played using a three buttons mouse, as usual with the X Window
System.  The left button (button 1) is used to uncover the square on which you
click (hoping that a mine is not hidden there).  The number displayed in an
uncovered square indicates how many mines are located around this square (for
example, a 3 means that there are three mines within the 8 surrounding
squares).  The whole game relies on the right use of these numbers.  The right
button (button 3) is used to place a flag on a square (this indicates that
there is a mine here).  If you click again with the right button on a square
that has a flag, the flag is changed into a question mark: this is useful if
you are trying to guess the possible location of some mine, you can use
question marks to think about it.  One more click with the right button and
the question mark disappears.  Clicking with the middle button (button 2) on
an uncovered square which has all its flags placed around uncovers the
surrounding cells which have no flags (this will save a lot of time).

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/mktools devel/imake pkgtools/cwrappers

Runtime dependencies

x11/libXpm

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64xdemineur-2.1.1nb2.tgz
NetBSD 10.0aarch64xdemineur-2.1.1nb2.tgz
NetBSD 10.0earmv6hfxdemineur-2.1.1nb2.tgz
NetBSD 10.0earmv6hfxdemineur-2.1.1nb2.tgz
NetBSD 10.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 10.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 10.0i386xdemineur-2.1.1nb2.tgz
NetBSD 10.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 10.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 10.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 10.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 8.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 8.0i386xdemineur-2.1.1nb2.tgz
NetBSD 8.0i386xdemineur-2.1.1nb2.tgz
NetBSD 8.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 8.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 8.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 8.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 8.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 9.0aarch64xdemineur-2.1.1nb2.tgz
NetBSD 9.0aarch64xdemineur-2.1.1nb2.tgz
NetBSD 9.0aarch64xdemineur-2.1.1nb2.tgz
NetBSD 9.0alphaxdemineur-2.1.1nb2.tgz
NetBSD 9.0alphaxdemineur-2.1.1nb2.tgz
NetBSD 9.0alphaxdemineur-2.1.1nb2.tgz
NetBSD 9.0alphaxdemineur-2.1.1nb2.tgz
NetBSD 9.0alphaxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv6hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv6hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv6hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0earmv7hfxdemineur-2.1.1nb2.tgz
NetBSD 9.0i386xdemineur-2.1.1nb2.tgz
NetBSD 9.0i386xdemineur-2.1.1nb2.tgz
NetBSD 9.0i386xdemineur-2.1.1nb2.tgz
NetBSD 9.0mips64ebxdemineur-2.1.1nb2.tgz
NetBSD 9.0mips64ebxdemineur-2.1.1nb2.tgz
NetBSD 9.0mips64ebxdemineur-2.1.1nb2.tgz
NetBSD 9.0mips64ebxdemineur-2.1.1nb2.tgz
NetBSD 9.0mips64ebxdemineur-2.1.1nb2.tgz
NetBSD 9.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 9.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 9.0powerpcxdemineur-2.1.1nb2.tgz
NetBSD 9.0sparc64xdemineur-2.1.1nb2.tgz
NetBSD 9.0sparc64xdemineur-2.1.1nb2.tgz
NetBSD 9.0sparc64xdemineur-2.1.1nb2.tgz
NetBSD 9.0sparc64xdemineur-2.1.1nb2.tgz
NetBSD 9.0sparc64xdemineur-2.1.1nb2.tgz
NetBSD 9.0sparcxdemineur-2.1.1nb2.tgz
NetBSD 9.0sparcxdemineur-2.1.1nb2.tgz
NetBSD 9.0sparcxdemineur-2.1.1nb2.tgz
NetBSD 9.0sparcxdemineur-2.1.1nb2.tgz
NetBSD 9.0sparcxdemineur-2.1.1nb2.tgz
NetBSD 9.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 9.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 9.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 9.0x86_64xdemineur-2.1.1nb2.tgz
NetBSD 9.0x86_64xdemineur-2.1.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.