Daemon Power

The NetBSD Packages Collection: finance/py-alpha_vantage

Brief description of the package:
Python wrapper for Alpha Vantage API for financial data

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/RomelTorres/alpha_vantage.

Please note that this package has a mit license.

The package is located in the "finance/py-alpha_vantage" directory. The current source version of the package is "py37-alpha_vantage-2.1.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for finance/py-alpha_vantage :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-pandas-[0-9]* py37-bottleneck-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.5 py37-numpy>=1.0 g95>=0.91 py37-cython>=0.12.1 blas>=1.0nb2 libtool-fortran>=2.4.2nb9 lapack>=3.1.1 blas>=1.0nb3 py37-dateutil>=2.5.0 py37-six>=1.5 py37-setuptools_scm-[0-9]* py37-matplotlib-[0-9]* py37-Pillow>=3.4 py37-olefile-[0-9]* freetype2>=2.8.1 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 libwebp>=0.6.0 py37-test-runner-[0-9]* py37-test>=2.8 py37-atomicwrites>=1.0 py37-attrs>=17.4.0 py37-packaging-[0-9]* py37-pyparsing>=2.0.2 py37-six-[0-9]* py37-pluggy>=0.12 py37-importlib-metadata>=0.12 py37-zipp>=0.5 py37-more-itertools-[0-9]* py37-setuptools_scm>=1.15.0 py37-py>=1.5.0 py37-six>=1.10.0 py37-wcwidth-[0-9]* py37-cairo-[0-9]* cairo>=1.13.1 Xrender>=0.2 x11-links>=1.31 osabi-NetBSD-8.0_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.11.91 fontconfig>=2.1nb2 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 cairo>=1.0.0nb2 cairo>=1.16.0 py37-cycler>=0.10 py37-dateutil>=2.1 py37-kiwisolver>=1.0.1 py37-setuptools-[0-9]* py37-pyparsing>=2.2.0 py37-numexpr-[0-9]* py37-pytz>=2011 py37-scipy>=0.7 fftw>=3.0 py37-numpy>=1.8.2 fftw>=3.1nb1 py37-sqlite3-[0-9]* py37-tables>=2.2 py37-cython-[0-9]* py37-numexpr>=2.6.2 py37-mock>=2.0 py37-six>=1.7 py37-six>=1.9.0 blosc>=1.12.1 lz4>=1.7.3<100 zstd>=1.3.6 lz4>=1.7.3 snappy>=1.0.5 googletest>=1.4.0 hdf5>=1.8.7 libaec>=1.0.4 hdf5>=1.8.11 py37-requests-[0-9]* py37-OpenSSL>=0.14 py37-cryptography>=2.8 py37-asn1crypto>=0.21.0 py37-cffi>=1.11.4 py37-cparser-[0-9]* py37-cparser>=2.10 py37-idna>=2.1 py37-six>=1.4.1 py37-six>=1.5.2 py37-certifi>=2017.4.17 py37-chardet>=3.0.2 py37-cryptography>=1.3.4 py37-idna>=2.5 py37-urllib3>=1.12.1 py37-Socks>=1.6.0 py37-certifi-[0-9]* py37-idna>=2.0.0 .

This package requires the following package(s) to run: py37-pandas-[0-9]* py37-bottleneck-[0-9]* py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 python37>=3.7.5 py37-numpy>=1.0 g95>=0.91 py37-cython>=0.12.1 blas>=1.0nb2 lapack>=3.1.1 blas>=1.0nb3 py37-dateutil>=2.5.0 py37-six>=1.5 py37-matplotlib-[0-9]* py37-Pillow>=3.4 py37-olefile-[0-9]* freetype2>=2.8.1 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 libwebp>=0.6.0 py37-cairo-[0-9]* cairo>=1.13.1 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.11.91 fontconfig>=2.1nb2 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 cairo>=1.0.0nb2 cairo>=1.16.0 py37-cycler>=0.10 py37-six-[0-9]* py37-dateutil>=2.1 py37-kiwisolver>=1.0.1 py37-setuptools-[0-9]* py37-pyparsing>=2.2.0 py37-numexpr-[0-9]* py37-pytz>=2011 py37-scipy>=0.7 fftw>=3.0 py37-numpy>=1.8.2 fftw>=3.1nb1 py37-sqlite3-[0-9]* py37-tables>=2.2 py37-cython-[0-9]* py37-numexpr>=2.6.2 py37-mock>=2.0 py37-six>=1.7 py37-six>=1.9.0 blosc>=1.12.1 lz4>=1.7.3<100 zstd>=1.3.6 lz4>=1.7.3 snappy>=1.0.5 hdf5>=1.8.7 libaec>=1.0.4 hdf5>=1.8.11 py37-requests-[0-9]* py37-OpenSSL>=0.14 py37-cryptography>=2.8 py37-asn1crypto>=0.21.0 py37-cffi>=1.11.4 py37-cparser-[0-9]* py37-cparser>=2.10 py37-idna>=2.1 py37-six>=1.4.1 py37-six>=1.5.2 py37-certifi>=2017.4.17 py37-chardet>=3.0.2 py37-cryptography>=1.3.4 py37-idna>=2.5 py37-urllib3>=1.12.1 py37-Socks>=1.6.0 py37-certifi-[0-9]* py37-idna>=2.0.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
i386:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
i386:py27-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
i386:py34-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
i386:py35-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
i386:py36-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
i386:py37-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
i386:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
i386:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
powerpc:py36-alpha_vantage-2.1.0.tgz(NetBSD 9.0)
powerpc:py37-alpha_vantage-2.1.0.tgz(NetBSD 9.0)
sparc64:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
sparc64:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
sparc64:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
sparc64:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
x86_64:py27-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
x86_64:py34-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
x86_64:py35-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
x86_64:py36-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
x86_64:py37-alpha_vantage-2.0.0.tgz(NetBSD 8.0)
x86_64:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
x86_64:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
x86_64:py36-alpha_vantage-2.1.0.tgz(NetBSD 8.0)
x86_64:py37-alpha_vantage-2.1.0.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]