editors/xemacs-current-nox11 - The NetBSD Packages Collection

*BETA* XEmacs text editor version 21.5 (no X11 support)

This is an unstable, *BETA* release of XEmacs.

XEmacs is a self-documenting, customizable, extensible real-time
display editor.

Users new to XEmacs will be able to use basic features fairly rapidly
by studying the tutorial and using the self-documentation features.
XEmacs also has an extensive interactive manual browser.  It is easily
extensible since its editing commands are written in Lisp.

XEmacs's many special packages handle mail reading (RMail) and sending
(Mail), outline editing (Outline), compiling (Compile), running
subshells within Emacs windows (Shell), running a Lisp read-eval-print
loop (Lisp-Interaction-Mode), automated psychotherapy (Doctor :-) and
many more. There is a WWW browsing mode written fully in elisp
that looks and behaves much like the netscape WWW browser.

XEmacs has similar functionality to GNU Emacs. It uses a different
display model, including support for Motif menu and scroll bars and the
ability to run as a widget inside other applications. Many people say
it looks nicer than GNU Emacs.

This package does not support X11.

Build dependencies

archivers/gtar-base lang/perl5 pkgtools/cwrappers

Runtime dependencies

databases/gdbm devel/gmp databases/gdbm devel/gmp

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxemacs-nox11-21.5.34nb9.tgz
NetBSD 8.0i386xemacs-nox11-21.5.34nb10.tgz
NetBSD 8.0i386xemacs-nox11-21.5.34nb9.tgz
NetBSD 8.0powerpcxemacs-nox11-21.5.34nb9.tgz
NetBSD 8.0powerpcxemacs-nox11-21.5.34nb10.tgz
NetBSD 8.0powerpcxemacs-nox11-21.5.34nb10.tgz
NetBSD 8.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 8.0x86_64xemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0aarch64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0aarch64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0alphaxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0alphaxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0earmv6hfxemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0earmv6hfxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0earmv6hfxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0earmv7hfxemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0earmv7hfxemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0earmv7hfxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0earmv7hfxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0i386xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0i386xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0m68kxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0powerpcxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0powerpcxemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0powerpcxemacs-nox11-21.5.34nb9.tgz
NetBSD 9.0powerpcxemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz
NetBSD 9.0x86_64xemacs-nox11-21.5.34nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

canna
Use Canna as Japanese conversion program.
debug
Enable debugging facilities in the package.
ldap
Enable LDAP support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.