editors/vim-gtk3 - The NetBSD Packages Collection

Vim editor (vi clone) with X11 GTK3 GUI

Vim is an almost compatible version of the UNIX editor Vi.  Many new features
have been added: multi level undo, syntax highlighting, command line history,
on-line help, filename completion, block operations, etc.

If you are building the package from source you may want to enable some
features such as a perl or python interpreter which are not enabled by
default.

This version also contains a X11 GTK3 GUI. If you don't have X11,
look at the `vim' package instead.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/glib2-tools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

editors/vim-share x11/gtk3 x11/libXpm x11/gtk3

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfvim-gtk3-8.2.3172nb3.tgz
NetBSD 8.0i386vim-gtk3-8.2.4214nb5.tgz
NetBSD 8.0i386vim-gtk3-8.2.2557nb3.tgz
NetBSD 8.0powerpcvim-gtk3-8.2.3172nb3.tgz
NetBSD 8.0powerpcvim-gtk3-8.2.3172nb5.tgz
NetBSD 8.0powerpcvim-gtk3-8.2.3172nb5.tgz
NetBSD 8.0x86_64vim-gtk3-8.2.4214nb5.tgz
NetBSD 8.0x86_64vim-gtk3-8.2.2557nb3.tgz
NetBSD 9.0aarch64vim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0aarch64vim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0alphavim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0alphavim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0earmvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0earmvim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0earmv6hfvim-gtk3-8.2.3172nb3.tgz
NetBSD 9.0earmv6hfvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0earmv6hfvim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0earmv7hfvim-gtk3-8.2.3172nb3.tgz
NetBSD 9.0earmv7hfvim-gtk3-8.2.3172nb3.tgz
NetBSD 9.0earmv7hfvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0earmv7hfvim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0i386vim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0i386vim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0mips64ebvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0mips64ebvim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0powerpcvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0powerpcvim-gtk3-8.2.3172nb3.tgz
NetBSD 9.0powerpcvim-gtk3-8.2.3172nb3.tgz
NetBSD 9.0powerpcvim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0sh3elvim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0sparc64vim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.4721nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.4721nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.3172nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.4214nb5.tgz
NetBSD 9.0x86_64vim-gtk3-8.2.4721nb5.tgz
NetBSD 9.99.96aarch64ebvim-gtk3-8.2.4214nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnome
Enable GNOME support.
lua
Enable Lua support.
luajit
Enable LuaJIT support.
perl
Enable Perl support.
python
Enable Python support.
ruby
Enable Ruby support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.