editors/jupp - The NetBSD Packages Collection

The portable version of joe from the MirOS project

This is the portable version of JOE.s Own Editord, using autoconf/automake.
This version has been enhanced by several functions intended for programmers
or other professional users, and has a lot of bugs fixed.
It is based upon an older version of joe because these behave better overall.

Basic differences between joe and jupp are:

* obviously, another flavour, jupp, similar to jstar
* utf-8 support on non-locale-aware OSses
* bug and security fixes
* tab completion fixes
* code cleanup
* compiles with -Wall -Werror (on MirBSD)
* improved options menu
* visibled spaces

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64jupp-3.1.41.tgz
NetBSD 10.0aarch64jupp-3.1.41.tgz
NetBSD 10.0aarch64ebjupp-3.1.41.tgz
NetBSD 10.0alphajupp-3.1.41.tgz
NetBSD 10.0alphajupp-3.1.41.tgz
NetBSD 10.0earmv4jupp-3.1.41.tgz
NetBSD 10.0earmv6hfjupp-3.1.41.tgz
NetBSD 10.0earmv6hfjupp-3.1.41.tgz
NetBSD 10.0earmv7hfjupp-3.1.41.tgz
NetBSD 10.0earmv7hfjupp-3.1.41.tgz
NetBSD 10.0i386jupp-3.1.41.tgz
NetBSD 10.0i386jupp-3.1.41.tgz
NetBSD 10.0powerpcjupp-3.1.41.tgz
NetBSD 10.0powerpcjupp-3.1.41.tgz
NetBSD 10.0sparc64jupp-3.1.41.tgz
NetBSD 10.0vaxjupp-3.1.41.tgz
NetBSD 10.0x86_64jupp-3.1.41.tgz
NetBSD 10.0x86_64jupp-3.1.41.tgz
NetBSD 9.0aarch64jupp-3.1.41.tgz
NetBSD 9.0aarch64jupp-3.1.41.tgz
NetBSD 9.0alphajupp-3.1.41.tgz
NetBSD 9.0alphajupp-3.1.41.tgz
NetBSD 9.0earmjupp-3.1.41.tgz
NetBSD 9.0earmv6hfjupp-3.1.41.tgz
NetBSD 9.0earmv6hfjupp-3.1.41.tgz
NetBSD 9.0earmv7hfjupp-3.1.41.tgz
NetBSD 9.0earmv7hfjupp-3.1.41.tgz
NetBSD 9.0i386jupp-3.1.41.tgz
NetBSD 9.0i386jupp-3.1.41.tgz
NetBSD 9.0m68kjupp-3.1.41.tgz
NetBSD 9.0mips64ebjupp-3.1.41.tgz
NetBSD 9.0powerpcjupp-3.1.41.tgz
NetBSD 9.0powerpcjupp-3.1.41.tgz
NetBSD 9.0sh3eljupp-3.1.41.tgz
NetBSD 9.0sparc64jupp-3.1.41.tgz
NetBSD 9.0sparc64jupp-3.1.41.tgz
NetBSD 9.0sparcjupp-3.1.41.tgz
NetBSD 9.0vaxjupp-3.1.41.tgz
NetBSD 9.0x86_64jupp-3.1.41.tgz
NetBSD 9.0x86_64jupp-3.1.41.tgz
NetBSD 9.3x86_64jupp-3.1.41.tgz
NetBSD 9.3x86_64jupp-3.1.41.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.