Daemon Power

The NetBSD Packages Collection: devel/ruby-rb-kqueue

Brief description of the package:
Ruby wrapper for BSD's kqueue, using FFI

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/mat813/rb-kqueue.

Please note that this package has a mit license.

The package is located in the "devel/ruby-rb-kqueue" directory. The current source version of the package is "ruby23-rb-kqueue-0.2.5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ruby-rb-kqueue :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-ffi>=0.5.0 ruby23-base>=2.3.4 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 libffi>=1.20 libffi>=3.0.11 .

This package requires the following package(s) to run: ruby23-ffi>=0.5.0 ruby23-base>=2.3.4 libyaml>=0.1.1 libyaml>=0.1.4 libffi>=1.20 libffi>=3.0.11 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
i386:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
i386:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
i386:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
i386:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
i386:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
i386:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
i386:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
i386:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
i386:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
i386:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
i386:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
i386:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
i386:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
i386:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
i386:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
i386:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
i386:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
powerpc:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 7.1)
powerpc:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 7.1)
powerpc:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 7.1)
powerpc:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 8.0)
powerpc:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 8.0)
powerpc:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 8.0)
x86_64:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
x86_64:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
x86_64:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 6.0)
x86_64:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
x86_64:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
x86_64:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 6.0)
x86_64:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
x86_64:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
x86_64:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 6.1)
x86_64:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
x86_64:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
x86_64:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 6.1)
x86_64:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
x86_64:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
x86_64:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 7.0)
x86_64:ruby21-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
x86_64:ruby22-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
x86_64:ruby23-rb-kqueue-0.2.4.tgz(NetBSD 7.0)
x86_64:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-rb-kqueue-0.2.5.tgz(NetBSD 8.99.1)
x86_64:ruby23-rb-kqueue-0.2.5.tgz(NetBSD 8.99.1)
x86_64:ruby24-rb-kqueue-0.2.5.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]