Daemon Power

The NetBSD Packages Collection: devel/ruby-atk

Brief description of the package:
Ruby binding of ATK-1.0.x or later

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://ruby-gnome2.osdn.jp/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "devel/ruby-atk" directory. The current source version of the package is "ruby24-atk-3.4.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ruby-atk :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby24-glib2>=3.4.1 ruby24-native-package-installer>=1.0.3 ruby24-base>=2.4.9 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby24-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 meson-[0-9]* ninja-build-[0-9]* python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.5 glib2>=2.34.0 atk>=1.11.4 glib2>=2.38.0 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gobject-introspection>=1.34.0 atk>=2.6.0 .

This package requires the following package(s) to run: ruby24-glib2>=3.4.1 ruby24-native-package-installer>=1.0.3 ruby24-base>=2.4.9 libyaml>=0.1.1 libyaml>=0.1.4 ruby24-pkg-config>=1.3.5 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.34.0 atk>=1.11.4 glib2>=2.38.0 python37>=3.7 libuuid>=2.18 python37>=3.7.0 atk>=2.6.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
earmv6hf:ruby26-atk-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
earmv7hf:ruby26-atk-3.3.8.tgz(NetBSD 8.0)
i386:ruby24-atk-3.3.8.tgz(NetBSD 7.0)
i386:ruby25-atk-3.3.8.tgz(NetBSD 7.0)
i386:ruby24-atk-3.3.8.tgz(NetBSD 7.1)
i386:ruby25-atk-3.3.8.tgz(NetBSD 7.1)
i386:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
i386:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
i386:ruby26-atk-3.3.8.tgz(NetBSD 8.0)
powerpc:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
powerpc:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
powerpc:ruby26-atk-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
sparc64:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby24-atk-3.3.8.tgz(NetBSD 7.0)
x86_64:ruby25-atk-3.3.8.tgz(NetBSD 7.0)
x86_64:ruby24-atk-3.3.8.tgz(NetBSD 7.1)
x86_64:ruby25-atk-3.3.8.tgz(NetBSD 7.1)
x86_64:ruby24-atk-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby25-atk-3.3.8.tgz(NetBSD 8.0)
x86_64:ruby26-atk-3.3.8.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]