devel/py-flake8-3 - The NetBSD Packages Collection

Modular source code checker for Python programs

Flake8 is a wrapper around these tools:

* PyFlakes
* pep8
* Ned Batchelder's McCabe script

Flake8 runs all the tools by launching the single flake8 script.
It displays the warnings in a per-file, merged output.

This package contains the last version supporting Python 2.x.

Build dependencies

devel/py-test-runner devel/py-setuptools44 pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/py-codestyle devel/py-flakes devel/py-mccabe06 devel/py-configparser devel/py-enum34 devel/py-functools32 devel/py-typing devel/py-importlib-metadata2 devel/py-setuptools44 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64py27-flake8-3.9.2nb3.tgz
NetBSD 10.0aarch64py27-flake8-3.9.2nb3.tgz
NetBSD 10.0earmv6hfpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0earmv6hfpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0earmv7hfpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0earmv7hfpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 10.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 10.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 10.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 8.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 8.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 8.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 8.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 8.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 8.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0aarch64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0aarch64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0aarch64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0alphapy27-flake8-3.9.2nb3.tgz
NetBSD 9.0alphapy27-flake8-3.9.2nb3.tgz
NetBSD 9.0alphapy27-flake8-3.9.2nb3.tgz
NetBSD 9.0alphapy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv4py27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv4py27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv4py27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv4py27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv6hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv6hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv6hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv7hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv7hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0earmv7hfpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 9.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 9.0i386py27-flake8-3.9.2nb3.tgz
NetBSD 9.0m68kpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0m68kpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0m68kpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mips64ebpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mips64ebpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mips64ebpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mips64ebpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mipselpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mipselpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mipselpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0mipselpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0powerpcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sh3elpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sh3elpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sh3elpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sh3elpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparc64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparc64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparc64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparc64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0sparcpy27-flake8-3.9.2nb3.tgz
NetBSD 9.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.0x86_64py27-flake8-3.9.2nb3.tgz
NetBSD 9.99.96aarch64ebpy27-flake8-3.9.2nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.