Daemon Power

The NetBSD Packages Collection: devel/ocaml-ppx_type_conv

Brief description of the package:
Support library for type-driven code generators

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/janestreet/ppx_type_conv/.

Please note that this package has a apache-2.0 license.

The package is located in the "devel/ocaml-ppx_type_conv" directory. The current source version of the package is "ocaml-ppx_type_conv-0.9.0nb5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ocaml-ppx_type_conv :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-jbuilder>=1.0_beta13nb1 ocaml-findlib>=1.2 ocaml>=4.07.0 cwrappers>=20150314 ocaml>=4.07.1 ocaml-findlib>=1.8.0nb2 ocaml-migrate-parsetree>=1.0.1 ocaml-result>=1.2 ocaml-jbuilder>=1.0_beta20nb1 ocaml-opaline>=0.3.1 ocaml-opam-file-format>=2.0.0beta ocaml-opam-file-format>=2.0.0beta3nb4 ocamlbuild>=0.9.2 ocamlbuild>=0.12.0nb2 ocaml-opaline>=0.3.1nb1 ocaml-result>=1.3nb1 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools-[0-9]* ocaml>=4.06.0 ocaml-cppo>=1.3.1 ocaml-ppx_derivers>=1.0 ocaml-cppo>=1.6.4nb1 ocaml-migrate-parsetree>=1.0.10 ocaml-ppx_derivers>=1.2nb1 ocaml-ppx_driver>=0.9.0 ocaml-ppx_core>=0.9.0 ocaml-compiler-libs>=0.9.0 ocaml-ppx_ast>=0.9.1 ocaml-compiler-libs>=0.11.0nb1 ocaml-ppx_traverse_builtins>=0.9.0 ocaml-stdio>=0.9.0 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-sexplib0>=0.11.0nb1 ocaml-sexplib>=0.9.0 ocaml-parsexp>=0.11.0 ocaml-num>=1.1 ocaml-parsexp>=0.11.0nb1 ocaml-num>=1.1nb2 ocaml-base>=0.11.1 ocaml-sexplib>=0.11.0nb1 ocaml-ppx_ast>=0.9.2nb2 ocaml-ppx_traverse_builtins>=0.9.0nb4 ocaml-stdio>=0.11.0nb1 ocaml-ppx_optcomp>=0.9.0 ocaml-ppxlib>=0.3.0 ocaml-ppxlib>=0.3.0nb2 ocaml-ppx_core>=0.9.2nb1 ocaml-ppx_optcomp>=0.11.0nb1 ocaml-ppx_metaquot>=0.9.0 ocaml-ppx_driver>=0.9.2nb2 ocaml-ppx_metaquot>=0.9.0nb4 ocaml-ppx_deriving>=4.2.1nb2 .

This package requires the following package(s) to run: ocaml-jbuilder>=1.0_beta13nb1 ocaml-findlib>=1.2 ocaml>=4.07.0 ocaml>=4.07.1 ocaml-findlib>=1.8.0nb2 ocaml-migrate-parsetree>=1.0.1 ocaml-result>=1.2 ocaml-jbuilder>=1.0_beta20nb1 ocaml-result>=1.3nb1 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools-[0-9]* ocaml>=4.06.0 ocaml-cppo>=1.3.1 ocaml-ppx_derivers>=1.0 ocaml-cppo>=1.6.4nb1 ocaml-migrate-parsetree>=1.0.10 ocaml-ppx_derivers>=1.2nb1 ocaml-ppx_driver>=0.9.0 ocaml-ppx_core>=0.9.0 ocaml-compiler-libs>=0.9.0 ocaml-ppx_ast>=0.9.1 ocaml-compiler-libs>=0.11.0nb1 ocaml-ppx_traverse_builtins>=0.9.0 ocaml-stdio>=0.9.0 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-sexplib0>=0.11.0nb1 ocaml-sexplib>=0.9.0 ocaml-parsexp>=0.11.0 ocaml-num>=1.1 ocaml-parsexp>=0.11.0nb1 ocaml-num>=1.1nb2 ocaml-base>=0.11.1 ocaml-sexplib>=0.11.0nb1 ocaml-ppx_ast>=0.9.2nb2 ocaml-ppx_traverse_builtins>=0.9.0nb4 ocaml-stdio>=0.11.0nb1 ocaml-ppx_optcomp>=0.9.0 ocaml-ppxlib>=0.3.0 ocaml-ppxlib>=0.3.0nb2 ocaml-ppx_core>=0.9.2nb1 ocaml-ppx_optcomp>=0.11.0nb1 ocaml-ppx_metaquot>=0.9.0 ocaml-ppx_driver>=0.9.2nb2 ocaml-ppx_metaquot>=0.9.0nb4 ocaml-ppx_deriving>=4.2.1nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:ocaml-ppx_type_conv-114.01+04nb1.tgz(NetBSD 6.0)
x86_64:ocaml-ppx_type_conv-0.9.0nb2.tgz(NetBSD 6.0)
x86_64:ocaml-ppx_type_conv-0.9.0nb2.tgz(NetBSD 6.1)
x86_64:ocaml-ppx_type_conv-0.9.0nb2.tgz(NetBSD 7.0)
x86_64:ocaml-ppx_type_conv-114.01+04nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ocaml-ppx_type_conv-0.9.0nb1.tgz(NetBSD 7.1)
x86_64:ocaml-ppx_type_conv-0.9.0nb2.tgz(NetBSD 7.1)
x86_64:ocaml-ppx_type_conv-0.9.0nb1.tgz(NetBSD 8.0)
x86_64:ocaml-ppx_type_conv-0.9.0nb2.tgz(NetBSD 8.0)
x86_64:ocaml-ppx_type_conv-0.9.0.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]