devel/ocaml-hxd - The NetBSD Packages Collection

Hexdump in OCaml

`hxd` is a little program to output a hexdump of a stdin or a binary file.
The main difference with `xxd` is to color outputs to be more fancy to read.
Then, it provides a way to generate a Caml code which is a dump of inputs.

Build dependencies

misc/ocaml-opaline misc/ocaml-opaline pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-cmdliner devel/ocaml-dune-configurator devel/ocaml-lwt devel/ocaml-dune devel/ocaml-findlib devel/ocaml-cmdliner devel/ocaml-dune-configurator devel/ocaml-lwt

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ocaml-hxd-0.3.2.tgz
NetBSD 10.0earmv6hfocaml-hxd-0.3.2.tgz
NetBSD 10.0earmv6hfocaml-hxd-0.3.2.tgz
NetBSD 10.0earmv7hfocaml-hxd-0.3.2.tgz
NetBSD 10.0earmv7hfocaml-hxd-0.3.2.tgz
NetBSD 10.0i386ocaml-hxd-0.3.2.tgz
NetBSD 10.0powerpcocaml-hxd-0.3.2.tgz
NetBSD 10.0powerpcocaml-hxd-0.3.2.tgz
NetBSD 10.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 10.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 8.0i386ocaml-hxd-0.3.2.tgz
NetBSD 8.0i386ocaml-hxd-0.3.2.tgz
NetBSD 8.0powerpcocaml-hxd-0.3.2.tgz
NetBSD 8.0powerpcocaml-hxd-0.3.2.tgz
NetBSD 8.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 8.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 9.0aarch64ocaml-hxd-0.3.2.tgz
NetBSD 9.0aarch64ocaml-hxd-0.3.2.tgz
NetBSD 9.0aarch64ocaml-hxd-0.3.2.tgz
NetBSD 9.0earmv6hfocaml-hxd-0.3.2.tgz
NetBSD 9.0earmv6hfocaml-hxd-0.3.2.tgz
NetBSD 9.0earmv7hfocaml-hxd-0.3.2.tgz
NetBSD 9.0earmv7hfocaml-hxd-0.3.2.tgz
NetBSD 9.0i386ocaml-hxd-0.3.2.tgz
NetBSD 9.0i386ocaml-hxd-0.3.2.tgz
NetBSD 9.0i386ocaml-hxd-0.3.2.tgz
NetBSD 9.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 9.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 9.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 9.0x86_64ocaml-hxd-0.3.2.tgz
NetBSD 9.0x86_64ocaml-hxd-0.3.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.