devel/ocaml-expect_test_helpers_core - The NetBSD Packages Collection

Helper library for writing expectation tests

Expect_test_helpers_core is a library intended for use with expect tests,
in particular stable types and allocation tests that use the Core.Gc
module.

Build dependencies

misc/ocaml-opaline misc/ocaml-opaline pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-base devel/ocaml-base_quickcheck devel/ocaml-core devel/ocaml-ppx_jane devel/ocaml-sexp_pretty devel/ocaml-stdio devel/ocaml-re devel/ocaml-dune devel/ocaml-findlib devel/ocaml-base devel/ocaml-base_quickcheck devel/ocaml-core devel/ocaml-ppx_jane devel/ocaml-stdio devel/ocaml-re

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0earmv6hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0earmv6hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0earmv7hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0earmv7hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0powerpcocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0powerpcocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 10.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0powerpcocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0powerpcocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 8.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0aarch64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0aarch64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0aarch64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0earmv6hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0earmv6hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0earmv7hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0earmv7hfocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0i386ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz
NetBSD 9.0x86_64ocaml-expect_test_helpers_core-0.15.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.