Daemon Power

The NetBSD Packages Collection: devel/js_of_ocaml

Brief description of the package:
Compiler of OCaml bytecode to Javascript

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://ocsigen.org/js_of_ocaml/.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "devel/js_of_ocaml" directory. The current source version of the package is "js_of_ocaml-3.1.0nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/js_of_ocaml :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-tyxml>=4.0.1 ocaml-findlib>=1.2 ocaml>=4.06.0 cwrappers>=20150314 ocaml>=4.06.1 ocaml-ppx_tools>=0.99.3 ocaml-findlib>=1.8.0nb1 ocaml-re>=1.6.0 ocaml-jbuilder>=1.0_beta13nb1 ocaml-jbuilder>=1.0_beta20 ocaml-opaline>=0.3.1 ocaml-opam-file-format>=2.0.0beta ocaml-opam-file-format>=2.0.0beta3 ocamlbuild>=0.9.2 ocamlbuild>=0.12.0 camlp4>=4.06 ocaml-markup>=0.7.2 ocaml-lwt>=4.0.0 ocaml-cppo>=1.3.1 ocaml-migrate-parsetree>=1.0.1 ocaml-result>=1.2 ocaml-result>=1.3 ocaml-ppx_tools_versioned>=5.0.1 ocaml-migrate-parsetree>=1.0.10 ocaml-cppo>=1.6.4 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=0.9.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-topkg>=0.9.1 ocaml-cmdliner>=1.0.2nb2 ocaml-uchar>=0.0.1nb1 ocaml-lwt>=4.0.1 ocaml-uutf>=1.0.1 ocaml-ppx_tools>=5.1 ocaml-re>=1.7.3 ocaml-markup>=0.7.6 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-react>=1.2.1nb3 ocaml-lwt_log>=1.1.0 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools-[0-9]* ocaml-ppx_derivers>=1.0 ocaml-ppx_derivers>=1.2 ocaml-tyxml>=4.2.0 ocaml-reactiveData>=0.2.1nb1 ocaml-ppx_deriving>=4.2.1 .

This package requires the following package(s) to run: ocaml-tyxml>=4.0.1 ocaml-findlib>=1.2 ocaml>=4.06.0 ocaml>=4.06.1 ocaml-ppx_tools>=0.99.3 ocaml-findlib>=1.8.0nb1 ocaml-re>=1.6.0 ocaml-jbuilder>=1.0_beta13nb1 ocaml-jbuilder>=1.0_beta20 camlp4>=4.06 ocaml-markup>=0.7.2 ocaml-lwt>=4.0.0 ocaml-cppo>=1.3.1 ocaml-migrate-parsetree>=1.0.1 ocaml-result>=1.2 ocaml-result>=1.3 ocaml-ppx_tools_versioned>=5.0.1 ocaml-migrate-parsetree>=1.0.10 ocaml-cppo>=1.6.4 ocaml-uutf>=0.9.3nb1 ocaml-topkg>=0.9.0 ocaml-cmdliner>=0.9.8 ocaml-uchar>=0.0.1 ocaml-topkg>=0.9.1 ocaml-cmdliner>=1.0.2nb2 ocaml-uchar>=0.0.1nb1 ocaml-lwt>=4.0.1 ocaml-uutf>=1.0.1 ocaml-ppx_tools>=5.1 ocaml-re>=1.7.3 ocaml-markup>=0.7.6 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-react>=1.2.1nb3 ocaml-lwt_log>=1.1.0 ocaml-ppx_deriving>=4.0 ocaml-ppx_tools-[0-9]* ocaml-ppx_derivers>=1.0 ocaml-ppx_derivers>=1.2 ocaml-tyxml>=4.2.0 ocaml-reactiveData>=0.2.1nb1 ocaml-ppx_deriving>=4.2.1 .

This package supports the following build-time options:

camlp4
Enable camlp4 support.
ocaml-tyxml
Enable OCaml-tyxml support

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 7.0)
i386:js_of_ocaml-2.8.3.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-3.1.0nb1.tgz(NetBSD 6.0)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 6.0)
x86_64:js_of_ocaml-3.1.0nb1.tgz(NetBSD 6.1)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 6.1)
x86_64:js_of_ocaml-3.1.0nb1.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-2.8.3.tgz(NetBSD 7.0.1_PATCH)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 7.1)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 7.1.1)
x86_64:js_of_ocaml-3.0.0nb1.tgz(NetBSD 7.1)
x86_64:js_of_ocaml-3.1.0nb1.tgz(NetBSD 8.0)
x86_64:js_of_ocaml-2.8.3.tgz(NetBSD 8.99.1)
x86_64:js_of_ocaml-3.0.0nb1.tgz(NetBSD 8.0)
x86_64:js_of_ocaml-3.0.0nb1.tgz(NetBSD 8.0)
x86_64:js_of_ocaml-3.0.2.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]