Daemon Power

The NetBSD Packages Collection: devel/ecore

Brief description of the package:
Event Abstraction and Modular Convenience Library

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://enlightenment.org/.

Please note that this package has a 2-clause-bsd license.

The package is located in the "devel/ecore" directory. The current source version of the package is "ecore-1.7.7nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ecore :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: eet>=1.7.7 eina>=1.7.7 jpeg>=8nb1 jpeg>=9 evas-buffer>=1.7.7 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 evas>=1.7.7 eet>=1.7.7nb1 fontconfig>=2.10.93nb2 evas>=1.7.7nb1 evas-software-x11>=1.7.0alpha x11-links>=0.91 osabi-NetBSD-6.1_STABLE xproto>=7.0.9 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 libXScrnSaver>=1.1.2 scrnsaverproto>=1.2.0 scrnsaverproto>=1.1.0 libXcomposite>=0.3.1 Xfixes>=2.0.0 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 Xfixes>=2.0.1nb2 compositeproto>=0.4 compositeproto>=0.3.1 xcursor>=1.0 Xrender>=0.8 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 damageproto>=1.1.0 libXp>=1.0.0 printproto>=1.0.3 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXtst>=1.0.1 recordproto>=1.13.99.1 recordproto>=1.13.1 xextproto>=7.0.99.3 curl>=7.35.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 .

This package requires the following package(s) to run: eet>=1.7.7 eina>=1.7.7 jpeg>=8nb1 jpeg>=9 evas-buffer>=1.7.7 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 evas>=1.7.7 eet>=1.7.7nb1 fontconfig>=2.10.93nb2 evas>=1.7.7nb1 evas-software-x11>=1.7.0alpha curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 libXScrnSaver>=1.1.2 libXcomposite>=0.3.1 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 libXp>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXtst>=1.0.1 curl>=7.35.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 .

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
arm:ecore-1.7.7.tgz(NetBSD 6.1_STABLE)
arm:ecore-1.7.7nb1.tgz(NetBSD 6.1_STABLE)
i386:ecore-1.7.7.tgz(MirBSD 10)
i386:ecore-1.7.7.tgz(MirBSD 10)
i386:ecore-1.7.7nb1.tgz(MirBSD 10)
i386:ecore-1.7.7nb1.tgz(NetBSD 5.1)
i386:ecore-1.7.7.tgz(NetBSD 5.1)
i386:ecore-1.7.7nb1.tgz(NetBSD 5.1)
i386:ecore-1.7.7nb1.tgz(NetBSD 5.1)
i386:ecore-1.7.7nb1.tgz(NetBSD 6.0)
i386:ecore-1.7.7.tgz(NetBSD 6.0)
i386:ecore-1.7.7.tgz(NetBSD 6.0)
i386:ecore-1.7.7.tgz(NetBSD 6.0)
i386:ecore-1.7.7nb1.tgz(NetBSD 6.0)
i386:ecore-1.7.7nb1.tgz(NetBSD 6.0)
powerpc:ecore-1.1.0nb1.tgz(NetBSD 5.1)
powerpc:ecore-1.1.0.tgz(NetBSD 5.1)
powerpc:ecore-1.1.0nb1.tgz(NetBSD 5.1)
powerpc:ecore-1.1.0nb2.tgz(NetBSD 5.2)
powerpc:ecore-1.7.7nb1.tgz(NetBSD 6.1_STABLE)
powerpc:ecore-1.1.0.tgz(NetBSD 6.0_BETA2)
powerpc:ecore-1.1.0nb1.tgz(NetBSD 6.0)
sparc64:ecore-1.1.0.tgz(NetBSD 5.1)
sparc64:ecore-1.1.0nb1.tgz(NetBSD 5.1)
sparc64:ecore-1.1.0nb2.tgz(NetBSD 5.1)
sparc64:ecore-1.1.0nb2.tgz(NetBSD 6.0_STABLE)
sparc64:ecore-1.7.7.tgz(NetBSD 6.1_STABLE)
sparc64:ecore-1.7.7nb1.tgz(NetBSD 6.1_STABLE)
sparc:ecore-1.7.7.tgz(NetBSD 6.0)
sparc:ecore-1.7.7.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 5.1)
x86_64:ecore-1.7.7.tgz(NetBSD 5.1)
x86_64:ecore-1.7.7.tgz(NetBSD 5.1)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 5.1)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 5.1)
x86_64:ecore-1.1.0nb4.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 6.0)
x86_64:ecore-1.7.7nb1.tgz(NetBSD 7.0_BETA)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]