databases/p5-DBIx-Class-IntrospectableM2M - The NetBSD Packages Collection

Introspect many-to-many shortcuts

Because the many-to-many relationships are not real relationships,
they can not be introspected with DBIx::Class. Many-to-many
relationships are actually just a collection of convenience methods
installed to bridge two relationships. This DBIx::Class component
can be used to store all relevant information about these
non-relationships so they can later be introspected and examined.

This module is fairly esoteric and, unless you are dynamically
creating something out of of a DBIC Schema, is probably the wrong
solution for whatever it is you are trying to do. Please be advised
that compatibility is not guaranteed for DBIx::Class 0.09000+. We
will try to mantain all compatibility, but internal changes might
make it impossible.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

databases/p5-DBIx-Class lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb5.tgz
NetBSD 8.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0powerpcp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0powerpcp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb5.tgz
NetBSD 8.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 8.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0aarch64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0aarch64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0aarch64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0alphap5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0alphap5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0alphap5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0i386p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0powerpcp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0powerpcp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0sparc64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0sparc64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0sparc64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.0x86_64p5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz
NetBSD 9.99.96aarch64ebp5-DBIx-Class-IntrospectableM2M-0.001002nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.