databases/p5-CatalystX-CRUD - The NetBSD Packages Collection

CRUD framework for Catalyst applications

CatalystX::CRUD provides a simple and generic API for Catalyst CRUD
applications. CatalystX::CRUD is agnostic with regard to data model
and data input, instead providing a common API that different
projects can implement for greater compatability with one another.

The project was born out of a desire to make Rose::HTML::Objects
easy to use with Rose::DB::Object and DBIx::Class ORMs, using the
Catalyst::Controller::Rose project. However, any ORM could implement
the CatalystX::CRUD::Model API, and any form management project
could use the resulting CatalystX::CRUD::Model subclass.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/p5-Catalyst-Component-ACCEPT_CONTEXT www/p5-Catalyst-Runtime devel/p5-Data-Dump devel/p5-Data-Pageset devel/p5-Moose devel/p5-MooseX-Emulate-Class-Accessor-Fast devel/p5-MRO-Compat devel/p5-Path-Class databases/p5-Search-QueryParser-SQL databases/p5-Sort-SQL lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0i386p5-CatalystX-CRUD-0.57nb4.tgz
NetBSD 8.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0x86_64p5-CatalystX-CRUD-0.57nb4.tgz
NetBSD 8.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 8.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0aarch64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0aarch64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0aarch64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0alphap5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0alphap5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0alphap5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv6hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv6hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv6hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv7hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv7hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv7hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0earmv7hfp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0i386p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0m68kp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0m68kp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0mips64ebp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0mips64ebp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0mips64ebp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0powerpcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sh3elp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sh3elp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sh3elp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sh3elp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparc64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparc64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparc64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0sparcp5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.0x86_64p5-CatalystX-CRUD-0.57nb5.tgz
NetBSD 9.99.96aarch64ebp5-CatalystX-CRUD-0.57nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.