Daemon Power

The NetBSD Packages Collection: cross/avrdude

Brief description of the package:
Downloader/uploader for Atmel AVR 8-bit RISC microcontrollers

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.nongnu.org/avrdude/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "cross/avrdude" directory. The current source version of the package is "avrdude-6.3nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for cross/avrdude :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libftdi>=0.18 libusb-compat>=0.1.6rc2 libusb1>=1.0.9 cwrappers>=20150314 libhid>=0.2 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 python27>=2.7.1nb2 libxslt>=1.1.28nb2 docbook-[0-9]* iso8879>=1986 swig>=1.3.24<2.0 swig>=1.3.31<2.0 libftdi1>=1.0 boost-libs-1.67.* icu>=3.4 icu>=61.1 boost-headers-1.67.* boost-jam-1.67.* confuse>=2.5 gettext-m4-[0-9]* gettext-tools-[0-9]* gettext-lib>=0.18 boost-libs>=1.67.0 libusb1-[0-9]* libelf>=0.8.5 dvipsk-[0-9]* tex-dvips>=2013 kpathsea>=3.5.7 kpathsea>=6.2.1 kpathsea>=6.0.0 tex-tetex-[0-9]* dialog>=1.0 kpathsea-[0-9]* tex-kpathsea>=2012nb1 tex-texlive.infra-[0-9]* tex-latex-fonts-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-tetex>=3.0.25424 tex-cm-[0-9]* tex-hyphen-base-[0-9]* tex-knuth-lib-[0-9]* tex-kpathsea-[0-9]* tex-tex-ini-files-[0-9]* tex-updmap-map-[0-9]* web2c-[0-9]* ptexenc>=1.3.4 zziplib>=0.10.82 cairo>=1.0.0nb2 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 xorgproto>=2016.1 libXau>=1.0 xcb-proto>=1.13 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* x11-links>=1.12 osabi-NetBSD-8.0_RC2 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 mpfr>=2.0.3 gmp>=5.0 gmp>=4.2.1 gmp>=5.0.1 poppler>=0.5.1 openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 ptexenc>=1.1.1 zziplib>=0.13.56 cairo>=1.14.12nb1 mpfr>=4.0.0 poppler>=0.66.0 poppler-includes>=0.22.2 poppler-includes>=0.66.0 tex-tetex>=3.0.27774 .

This package requires the following package(s) to run: libftdi>=0.18 libusb-compat>=0.1.6rc2 libusb1>=1.0.9 libhid>=0.2 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 python27>=2.7.1nb2 libxslt>=1.1.28nb2 libftdi1>=1.0 boost-libs-1.67.* icu>=3.4 icu>=61.1 confuse>=2.5 boost-libs>=1.67.0 libelf>=0.8.5 readline>=2.2 readline>=6.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:avrdude-6.1nb1.tgz(NetBSD 7.0)
earmv6hf:avrdude-6.1nb1.tgz(NetBSD 7.0)
earmv7hf:avrdude-6.1nb1.tgz(NetBSD 7.0)
i386:avrdude-6.3.tgz(NetBSD 6.0)
i386:avrdude-6.3nb1.tgz(NetBSD 7.0)
i386:avrdude-6.1nb1.tgz(NetBSD 7.0)
i386:avrdude-6.1nb1.tgz(NetBSD 7.0)
i386:avrdude-6.3.tgz(NetBSD 7.0)
i386:avrdude-6.3.tgz(NetBSD 7.0)
i386:avrdude-6.3.tgz(NetBSD 7.0)
i386:avrdude-6.3nb1.tgz(NetBSD 7.0)
i386:avrdude-6.3nb1.tgz(NetBSD 7.1)
i386:avrdude-6.3.tgz(NetBSD 7.1)
i386:avrdude-6.3nb1.tgz(NetBSD 7.1)
i386:avrdude-6.3nb1.tgz(NetBSD 8.0)
i386:avrdude-6.3.tgz(NetBSD 8.0)
powerpc:avrdude-6.3.tgz(NetBSD 6.1)
powerpc:avrdude-6.3nb1.tgz(NetBSD 8.0)
sparc64:avrdude-6.1nb1.tgz(NetBSD 7.0)
x86_64:avrdude-6.3nb1.tgz(NetBSD 7.0)
x86_64:avrdude-6.3.tgz(NetBSD 7.0)
x86_64:avrdude-6.3.tgz(NetBSD 7.0)
x86_64:avrdude-6.3nb1.tgz(NetBSD 7.0)
x86_64:avrdude-6.3.tgz(NetBSD 7.0.1_PATCH)
x86_64:avrdude-6.3nb1.tgz(NetBSD 7.1)
x86_64:avrdude-6.3.tgz(NetBSD 7.1.1)
x86_64:avrdude-6.3nb1.tgz(NetBSD 7.1.1)
x86_64:avrdude-6.3.tgz(NetBSD 7.1)
x86_64:avrdude-6.3nb1.tgz(NetBSD 8.0)
x86_64:avrdude-6.3.tgz(NetBSD 8.99.1)
x86_64:avrdude-6.3.tgz(NetBSD 8.0)
x86_64:avrdude-6.3.tgz(NetBSD 8.0)
x86_64:avrdude-6.3nb1.tgz(NetBSD 8.0)
x86_64:avrdude-6.3.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]