cross/64tass - The NetBSD Packages Collection

Cross-assembler for 6502-like processors

64tass is cross assembler targeting the 65xx series of micro processors.

Features:
- Open source portable C with minimal dependencies
- Familiar syntax to Omicron TASS and TASM
- Supports 6502, 65C02, R65C02, W65C02, 65CE02, 65816, DTV, 65EL02, 4510
- Arbitrary-precision integers and bit strings, double precision floating point
  numbers
- Character and byte strings, array arithmetic
- Handles UTF-8, UTF-16 and 8 bit RAW encoded source files, Unicode character
  strings
- Supports Unicode identifiers with compatibility normalization and optional
  case insensitivity
- Built-in "linker" with section support
- Various memory models, binary targets and text output formats (also
  Hex/S-record)
- Assembly and label listings available for debugging or exporting
- Conditional compilation, macros, structures, unions, scopes

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch6464tass-1.59.3120.tgz
NetBSD 10.0aarch64eb64tass-1.59.3120.tgz
NetBSD 10.0alpha64tass-1.59.3120.tgz
NetBSD 10.0earmv6hf64tass-1.59.3120.tgz
NetBSD 10.0earmv7hf64tass-1.59.3120.tgz
NetBSD 10.0i38664tass-1.59.3120.tgz
NetBSD 10.0x86_6464tass-1.59.3120.tgz
NetBSD 8.0i38664tass-1.59.3120.tgz
NetBSD 8.0powerpc64tass-1.59.3120.tgz
NetBSD 8.0x86_6464tass-1.59.3120.tgz
NetBSD 9.0aarch6464tass-1.59.3120.tgz
NetBSD 9.0alpha64tass-1.59.3120.tgz
NetBSD 9.0earmv6hf64tass-1.59.3120.tgz
NetBSD 9.0earmv7hf64tass-1.59.3120.tgz
NetBSD 9.0i38664tass-1.59.3120.tgz
NetBSD 9.0powerpc64tass-1.59.3120.tgz
NetBSD 9.0x86_6464tass-1.59.3120.tgz
NetBSD 9.3x86_6464tass-1.59.3120.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.