Daemon Power

The NetBSD Packages Collection: benchmarks/phoronix-test-suite

Brief description of the package:
Phoronix Benchmarking Suite

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.phoronix-test-suite.com/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "benchmarks/phoronix-test-suite" directory. The current source version of the package is "phoronix-test-suite-8.8.1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for benchmarks/phoronix-test-suite :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php71-curl>=5.3 php>=7.0.99<7.1.99 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 cwrappers>=20150314 readline>=2.2 libxml2>=2.8.0nb2 readline>=6.0 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 nghttp2>=1.39.2nb1 curl>=7.65.3nb3 php71-gd>=5.3 gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gd>=2.2.5nb2 php71-json>=5.3 php71-pcntl>=5.3 php71-posix>=5.3 php71-zip>=5.3 libzip>=0.7.1 libzip>=1.5.2nb1 php71-zlib>=5.3 shared-mime-info>=0.15 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.5 glib2>=2.34.0 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 shared-mime-info>=1.0nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 .

This package requires the following package(s) to run: php71-curl>=5.3 php>=7.0.99<7.1.99 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 libxml2>=2.8.0nb2 readline>=6.0 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 nghttp2>=1.39.2nb1 curl>=7.65.3nb3 php71-gd>=5.3 gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gd>=2.2.5nb2 php71-json>=5.3 php71-pcntl>=5.3 php71-posix>=5.3 php71-zip>=5.3 libzip>=0.7.1 libzip>=1.5.2nb1 php71-zlib>=5.3 shared-mime-info>=0.15 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 shared-mime-info>=1.0nb1 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
alpha:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
alpha:phoronix-test-suite-8.8.1.tgz(NetBSD 8.0)
earm:phoronix-test-suite-3.4.0nb1.tgz(NetBSD 7.0)
earm:phoronix-test-suite-8.8.1.tgz(NetBSD 8.0)
earmv6hf:phoronix-test-suite-3.4.0nb1.tgz(NetBSD 7.0)
earmv6hf:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
earmv7hf:phoronix-test-suite-3.4.0nb1.tgz(NetBSD 7.0)
earmv7hf:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
i386:phoronix-test-suite-3.4.0nb1.tgz(MirBSD 10)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
i386:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
mips64eb:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
powerpc:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
powerpc:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
sparc64:phoronix-test-suite-8.8.1.tgz(NetBSD 8.0)
sparc64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 7.1)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)
x86_64:phoronix-test-suite-3.4.0nb2.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]